EXOscada Viewer SCADA system for the EXO system

EXOscada requires Adobe Flash Player to run.
Adobe Flash Player went End of Life (EOL) on December 31st, 2020. By then, all major web browsers stopped running the application.
Our product EXOscada is impacted by the Adobe End of Life and we strongly advise you to install the EXOscada Viewer to avoid a system disruption.
To get EXOscada Viewer for your installation, please contact Regin or your certified Regin system installer.

Navigate on this page